Sn0wbreeze 2.2 For Windows: iOS 4.2.1 Untethered Jailbreak For iPhone, iPad & iPod Touch Released; Fixes iBooks Problem

Sn0wbreeze v2.0

iH8sn0w has released Sn0wbreeze 2.2 for Windows, which allows users who want to jailbreak and also unlock their iPhone to update their iPhone with a pre-jailbroken iOS 4.2.1 firmware while preserving the baseband from getting upgraded so that it can be unlocked using Ultrasn0w.

Sn0wbreeze is considered as the unofficial PwnageTool for Windows. iPhone Dev Team have already released PwnageTool 4.2 for Mac.

Sn0wbreeze 2.2 allows users to create custom iOS 4.2.1 firmware file that is pre-jailbroken, which can be used to upgrade their iPhone, iPad or iPod Touch to iOS 4.2.1. In case of iPhone, it also preserves the baseband from getting upgraded so that it can be unlocked using Ultrasn0w using the “Baseband Preservation Mode”.

Sn0wbreeze 2.1 supports the following devices:

Sn0wbreeze also allows users to change boot logos and also fixes the iBooks issue, which we had reported yesterday. As a bonus, you can also play Pac-Man while the custom iOS 4.2.1 firmware file is being built.

Please note that jailbreaking your iDevice may void its warranty so proceed with caution and at your own risk. Please don’t forget to backup your iPhone before you proceed. You can refer to this post for instructions on how to backup your iPhone.

You can download Sn0wbreeze 2.2 from iH8sn0w’s website.

Update 1:

Please note that Ultrasn0w 1.2 unlocks iPhone 4 baseband 01.59.00 and iPhone 3G/3GS basebands 04.26.08, 05.11.07, 05.12.01, 05.13.04 and 06.15.00.

iPad and iPod Touch users are better off using Greenpois0n as you don’t need to preserve baseband like iPhone users and also assuming that the iBooks problem is a non-issue for you.

Update 2:

Sn0wbreeze 2.2: iOS 4.2.1 Untethered Jailbreak Updated To Fix iBooks Issue Reported By Some Users

As always, please let us know how it goes.

[via iH8sn0w]

Like this post? Share it!

  • Kyle

    I’m confused. I have 4.1 on my IPhone 4. Can I finally unlock now?

    Kyle

    • Thor

      That depends on your baseband. Post version number.

  • Thor

    Not clear if snowbreeze includes iBook fixes. Any confirmation?

    • http://www.iphonehacks.com/ iPhoneHacks

      Sn0wbreeze 2.2 includes fix for iBooks, we have updated the post accordingly. Thanks for pointing it out.

  • paul

    I have iphone 4 on 4.2.1 and modem firmware 3.10.01. Can I use this to unlock?

    • http://www.iphonehacks.com/ iPhoneHacks

      Sn0wbreeze is used to jailbreak iPhone and then you need to install Cydia to software unlock.

      Unfortunately, Ultrasn0w 1.2 does not support baseband 03.10.01.it.

      • Paulo

        i have iphone 4 AT&T iOs 4.2.1 firmware 03.10.01, im using gevey sim, i want to jailbreak it, is jailbreaking can remove the unlock? bec if jailbreaking updated the firmware to 4.11.08 it will stock on lock. please any suggestion or comments, Thanks a lot, more power to your web site

      • Paulo

        jailbreak and preserve basedband 03.10.01 and use gevey sim, is that possible??? pls help!!

    • DiabloZoe

      NO

  • Tom

    Can I use snowbreeze 2.2 to upgrade my iphone 3gs with baseband 3.1.2 and keep my iphone unlocked? I still using version 3.1.2 b/c I need to keep my iphone unlock. Can i upgrade to 4.2.1 ?

    • DiabloZoe

      It depends on what your BB is!! If your still on 3.1.2 then I think your BB is 5.11.07? So yes!! If your are unlocked before you use SB 2.2 then you will be unlocked after!

  • NorGod

    can use the “Baseband Preservation Mode” on iPad??

    • http://www.iphonehacks.com/ iPhoneHacks

      No point for an iPad, that mode is meant for iPhone users who want to preserve the baseband so it can be unlocked using Ultrasn0w.

  • Thanga

    Can I use snowbreeze 2.2 to Jailbreak and unlock my iphone 4 with IOS 4.2.1 Baseband 03.10.01.
    Thanx.

    • DiabloZoe

      No you cannot!

  • shane

    What about 06.15.00 downgrade for 3G users that are not on 5.8 bootloader? I want the GPS Back!

  • tomas

    i have a 3GS on 4.2.1 bb 6.15.00
    any news on the GPS fix????

  • nuraj

    i have iphone 3gs on 5.15.04 and on ios 4.1 which is’nt unlocked yet. can i update my baseband to 6.15.0 using redsnow and later can i again use snowbreeze 2.2 so dat i will get an untethered jailbreak and hence can also can unlock as i have ultrasnow supports 6.15.0. Pls help is it possible or should i wait for the release of anythin else..!!!

    • DiabloZoe

      It sucks being on a unlockable BB, but do not upgrade to 6.15!!! Way to many problems!!!

  • IGuy

    can this jailbreak ipod touch 2g non MC model? i tried it, but when i install cydia, it refuse to start.

  • Rush

    Iphone 4 IOS 4.2.1 simple mode done!

  • cowcrap

    1) Any gps fix out for 3G/3GS users?

    2) Will Sn0wbreeze 2.2 be able to downgrade the bb of my iPhone 3GS and fix the GPS issue?

    • http://www.iphonehacks.com/ iPhoneHacks

      Dev Team haven’t mentioned anything about fixing the GPS issues or ability to downgrade baseband 06.15.00 so doesn’t look like it.

      We’ll let you know if we get any further updates.

  • RASTA

    Can I use snowbreeze 2.2 to Jailbreak and unlock my iphone 4 with IOS 4.2.1 Baseband 03.10.01.
    Thanx.

    • http://www.iphonehacks.com/ iPhoneHacks

      Sn0wbreeze allows users to jailbreak their iPhone and also preserve the baseband. After jailbreaking they need to install Ultrasn0w 1.2 via Cydia to software unlock their iPhone.

      Ultrasn0w 1.2 does not support baseband 03.10.01, so you won’t be able to unlock your iPhone 4.

      • Paulo

        (iPhone 4 iOs 4.2.1 firmware 03.10.01) if ultrasnow 1.2 does not unlock this kind of version what if i jailbreak it and preserve the basedband then i will use gevey sim, will that work?

  • nuraj

    i have iphone 3gs on 5.15.04 and on ios 4.1 which is’nt unlocked yet. can i update my baseband to 6.15.0 using redsnow and later can i again use snowbreeze 2.2 so dat i will get an untethered jailbreak and hence can also can unlock as i have ultrasnow supports 6.15.0. Pls help is it possible or should i wait for the release of anythin else..!!!

  • http://www.iphonehacks.com/ iPhoneHacks

    We would recommend to avoid updating 06.15.00 as users have reported GPS issues.

    Dev Team has also not come with a method to downgrade baseband.

    • Avomania

      heyy:D plz help i will jailbreak and unlock my iphone 4 4.2.1 i downloaded sn0wbreeze 2.2 an 4.2.1 software i am confused .. what should i choose baseband preserving mod or simple mod.. i want to hav cydia to plz help:D

  • V

    Sn0wbreeze 2.2 is buggy!!! Do not use it!!

    • P

      How is it buggy? Let us know and maybe we will get a fix for it.

  • UnlockDesp

    I have iPhone 4. Firmware 02.10.04 and version 4.1 (8B117). Please help me and tell me how I can unlock.
    Thanks.

    • UnlockDesp

      Still waiting for a reply…

      • Lavender

        Baseband 2.10.04 can’t be unlocked. If you can use redsn0w to update the baseband to 6.15.00 (not sure if your baseband is newer than 6.15.00, in which case you wouldn’t be able to update) …you should be able to unlock that – but the 6.15.00 baseband is a very blatant hack. I think Apple will be able to detect it and possibly disable your phone in the future. Also you may have GPS troubles.

        You can try it, but I think it’s best to wait for an update to ultrasn0w, or a new method that can unlock a legitimate baseband.

        • UnlockDesp

          Thanks… I guess I’l wait.

  • badboykilla

    @ nuraj – yes! go for it. since you are already on 5.15.04 which isnt unlockable yet. Use Redsnow 0.9.6b5 which will allow you to upgrade your iPhone 3GS / 3G baseband to 06.15.00, then unlock it with ultrasnow.

  • badboykilla

    @ nuraj – there are some GPS issues at the moment with 06.15.00. If you really need ur iPhone unlocked then go for it. If not then wait!

  • nuraj

    thnks badboykilla..!!! one more thing, if i update it with 6.15.00 using redsnow, can i again jailbreak it with snowbreeze so that i will get an untethered jailbreak.. and hence can also unlock it..

    • Lavender

      If you know how to use sn0wbreeze, you should be able to update to iOS 4.2.1 untethered jailbreak. If you already used redsn0w to update baseband to 6.15.00 then that should stay as it is – and ultrasn0w 1.2 can already unlock that.

      HOWEVER: I think Apple may in the future be able to detect and disable your device, because an iphone with baseband 6.15.00 is very *obviously* hacked/jailbroken. Your GPS may also stop working.

      Therefore – it’s your choice. Personally, I wouldn’t use redsn0w. I would WAIT for a newer version of ultrasn0w which can unlock your 5.14.04 – hopefully coming soon.

  • http://n/a Jez

    Does 2.2 for ipad provide me with cydia app straight off or do i have to do some other thing to install cydia? Happily running jailbroken 3.2.1 so have been reluctant to update

    • Bermuda Brains

      You can update your iPad to 4.2.1 through iTunes as normal, after that you can use greenpoison to J/B. it will add a “loader” app which you can use to install Cydia. It”s that simple. I have done a half dozen iPads and it work great.

  • http://www.motorbeam.com/ fas

    This was quick by the JB team.

  • JBer

    what about BB 05.14.02? Can it be unlocked?

  • Warezchewy

    I have 3GS with baseband 6.15.00 old bootrom

    Does anyone know if this will fix the GPS issue

    I miss my TomTom

    • Lavender

      I think it won’t fix your problem. Your problem is the hacked baseband – until you can update your baseband, I think your GPS will stay broken-ish. When a newer baseband is released, you may be able to update to it, but it may not be able to be unlocked. Also, if I’ve understood correctly, there may be a risk of Apple flagging your baseband as a hacked device (iphone with an ipad exclusive baseband) if you connect through them to update – and they might take hostile action! I could be wrong though :P

  • eXistenZ

    This way of jailbreak activate the iPhone or I will need the oficial carrier SIM to activate on iTunes!?

  • Icem4n7

    Have there been any reported issues with sn0wbreeze? I just used it on my iPhone 4 (upgraded to 4.2.1 from 4.0.1), unlocked and everything seemed fine but when I go to enter in the network settings in the “network” tab it stalls for a very long time before it let’s me in; and then the option to edit my network settings isn’t there (mms, data, tethering). Is there anything I could do to fix this? (downgrading the firmware being a last resort, and I have it on tmobile) =(

    • Techz

      I have the same problem. Network settings stalls, then open with no option to edit any of the settings for things like tethering APN etc.., and now my edge isn’t working. Help!!!!!!!

  • sonicpuke

    Everytime I use the newer version of Ireb or Ihatesn0w I can’t see the text on the buttons, they are always black on black no text that I can see

    I get stuck trying to guess which button is which, which isn’t a good option when messing around with my $400 phone

    I’ve googled for info on this but didn’t find anything? Am I the only one? What the H?

    • V

      Facing the same issue buddy :-(

    • V

      SOLVED!!! downloaded sn0wbreeze for the fifth time and changed my lappy’s color settings and it worked!!!

  • Langzi

    I have an iphone 3G was running IOS 4.01 and I jailbroken it with redsn0w and unlocked with BB 6.15.0. Due to some reasons I downgraded to firmware 3.1.3 and stuck on this version now. Can I use Sn0wbreeze upgrade to IOS 4.2.1?

  • Yo Mama

    I used this last night to upgrade a 3GS (new bootrom) from 4.1 with a baseband for 3.1 or something like that (think I used redsn0w for the 4.1 upgrade…) I did NOT use the hacktivate option, but when it was done, I had no signal at all.
    I had to use cydia and wireless to download SAM and restore original lockdownd for iTunes to activate the phone before it would work. Installing ultrasn0w (which I don’t exactly need because I’m on the official carrier, but I travel a lot so…) made the signal go away again.
    I uninstalled ultrasn0w and respringed and now it’s fine. But looks like there’s a problem somewhere…

  • JhonnyBRAVA

    how about mine I have Iphone 4 02.10.04 baseband can I unlock it?

    • Thor

      Net yet

  • rocky choi

    my iphone 4 is on 4.1 & baseband 01.59.00 already unlock using ultrasn0w, so if i use sn0wbreeze, to jailbreak 4.2.1 , of course the baseband will be the same 01.59.00, do i need to run ultrasn0w again
    thanks

  • richard

    hello guys
    just a quick one i have a iphone 3g on 4.2.1(8c148) modem firmware is 05.15.04 all i need is to jailbreak it dont need it unlocked just need to get cydia back on my phone
    thanks
    rich
    ps keep up the good work guys

  • Jayson

    Something that would be funny is that I go to Sams Club and go to the iPad, I had my netbook (I don’t have one!) and then connect the iPad, open greenpois0n, then JAILBREAK IT! Then people come by, I put up a sign that says: “TEST OUT A JAILBROKEN IPAD!” I walk away like nothing ever happened so a sales accosite wouldn’t be suspicous.

  • Sallah

    I have iphone 4 on 4.1, using baseband preserving mode. I’m unable to restore & keep getting a message (error 1600) from itunes, the device is already in DFU mode as per instructions …. please advise ???

    • Sallah

      SOLVED !!!

      • Nico

        How do you solve that? I have the same error 1600 after restoring the IPSW modified by Sn0wbreeze: sn0wbreeze_iPhone 3GS-4.2.1a.ipsw

      • m

        yeah do tell

  • Crow

    When using the basement petection mode, it doesnt allow you to use the expert mode options. Does it matter about expert mode options? Is there something I’m missing?

  • http://www.gyemen.com Ahmed

    Very Excellent … waiting for more >>>>> Th4nx

  • Lavender

    Will iphonehacks make a nice friendly guide for iphone3gs windows users to jailbreak and unlock? Pretty please! :D

  • V

    Worked flawlessly..iPhone 3gs on 4.2.1 JB with sn0wbreeze with baseband 5.13.02..unlocked with ultrasn0w…:-) Big thanks DEV TEAM..!!!

    • Lavender

      Do you really mean baseband 5.13.02 or did you mean 5.13.04? Which is what I’ve got on my jailbroken 4.0.1.

  • http://aussiecriminals.wordpress.com/ Snidley Whiplash

    All I want is to get GPS back on my phone.It is one of the best features on the iphone yet does not work with my phone(Model MC133X, Version 4.2.1 (8C148A) 06.15.00 baseband. Its been a few months now and still no fix…Pain the in ass, are there any work arounds to get GPS back?

  • Sumo

    I got new iphone 4 version 4.2.1 and modem Firmware 03.10.01, jailbroken with greenpois0n 5 and still waiting DEV help way to unlock.

  • Ed

    what is the difference between greenpois0n and sn0wbreeze? i have a 3gs that is jailbroken with newest version of greenpois0n and it works like a charm but would it benefit me to try sn0wbreeze instead? i may someday want to unlock my iphone and be able to purchase ibooks and be able to read them without the hassle of piracy protection but not at the moment, any information would be appreciated and very helpful, thanks, Ed

  • http://google kim

    I have an 3G iphone on baseband 05.15.04 and I can not unlock. I have tried using the Redsn0w but it gets stuck at waiting to reboot(everytime). I jailbroke with Greenpois0n last week but how can I unlock, will sn0wbreeze 2.2 unlock? I dont want to upgrade to the ipad baseband because I wont be able to go back can you please help?

  • http://infohacks.net UmiSan

    when will unlock for baseband 3.10.01 be out?

  • Raja

    i have iphone 3gs on 5.15.04 and on ios 4.1 which is’nt unlocked yet. Is it possible to unlock using Sn0wbreeze and Ultrasn0w. Or I need wait for some time to get full unlockable Ultrsn0w.

  • Meidas

    Hi guys. Have anyone tried this on iPhone 4?

  • http://www.zain.co.ug nsereko

    how can i unlock ios 4.2.1 with baseband 05.15.04,it doesn’t unlock using snowbreeze 2.2 i keep getting error 21 in itune

  • http://www.zain.co.ug nsereko

    am using iphone 3gs

  • shinigami08

    i have an iphone 3gs, jailbreaked with spirit, unlocked, at fw 3.1.3, bb 5.12.01, mc model. is this snowbreeze unthetered? do i need any specific instructions on how to use snowbreeze on my phone? im just a newbie at this…

    • Mr D

      I had the exact same phone, 3gs, jailbroke with Spirit, fw 3.1.3 and baseband 5.12.01.

      I upgraded yesterday and ran into a few problems. 1st got error 21 then error 1600, fixed this by downloading iREB and forcing the phone into DFU mode. After jailbreaking I had no signal, fixed this by going to Cydia and installing Ultrasn0w (guess I’m unlocked now – but didn’t need it). Then YouTube wouldn’t work, fixed this by going to Cydia and installing Push Doctor (Had to REBOOT to make it work). I also have no GPS now. If I know this was going to happen I would have stayed on 3.1.3.

      @iH8sn0w, whats the deal with no GPS, is there a workaround? Can I use SAM and reactivate? Come on!! How do we fix GPS??????

      • Mr D

        I also have the new bootrom MC. Forgot to mention this.

        • Yo Mma

          I had the same no signal problem and I posted up above, so if you read your question would have already been answered (sort of). I installed SAM and used the option to revert to stock lockdownd and almost as soon as I did, itunes activated the phone. GPS and everything works, but the funny thing is that if I install ultrasn0w, I loose my signal again…

  • morf

    hey guys, i have an 3gs 4.0.0 (8A293) with 05.13.04 BB unlocked by ultrasn0w. so with snowbreeze 2.2 i can finally upgrate to 4.2.1 and have it jailbroken too. i have NO shsh for 4.0 but SHSH files for 4.1 and 4.2.1.

    so once i’m on 4.2.1, the only option to downgrade is 4.1 with snowbreeze 2.1??? is this possible?

    runs the 4.2.1 jailbreak stabile on your iphone?

  • JBer

    3G iOS 4.1 BB 05.14.02 – can it be unlocked?

  • ReadPPL

    I love people dont read instructions. This JB’ing stuff isnt hard people! Just slow the F down and READ… R.E.A.D READ!!!! The answer to 98% of your questions can be answered if you just READ!

  • iGuy

    Great work Guys!

  • aai

    I ‘ve done evry thing right but it seems that there is something wrong with sn0wbreeze as I lost my carrier bar and I have no service on my iphone can any one help

  • xpitxbullx

    I don’t see a newly created IPSW. Does it modify the one you select when you start sn0wbreeze?

    • xpitxbullx

      Desktop. Last place I looked. Haha

  • http://la_la@yahoo.ca Moron

    No hpoe for 5.15.04 baseband owners just switch from your expensive ipod to samsung galaxy !!!

  • Moron

    Hey why banning my opinion ?

    Its free world pal ???

    Is it wrong to suggest to switch users who cant unlock their expensive ipod to samsung galaxy ?

    whats wrong ???

  • mishy

    i tried to extract it, and norton blocked it saying it was a virus…anyone else with this issue?

  • jamesh

    help no cydia after jailbreak

  • Nisan

    Had iPhone 4 iOS 4.0 unlocked with ultradsn0w.

    Just tried the upgrade procedure and everything seems to be going just fine.

    I saw the snow icon on my iPhone followed by an apple (official) icon.

    Now the iPhone is back in a “need to be activated” mode and I dont have an AT&T sim card.

    I’m thinking about going and buy 1, do you have any advice on how to proceed ? I am not even sure what’s my baseband anymore.

    I noticed snowbreez can do hacktivate but that’s for “expert” mode – will it save my baseband ?

    Thanks,
    Nisan

  • bathroom

    3gs old bootrom, 05.12.01, from 3.1.3 to 4.2.1 updated and unlocked!!!
    running smooth

    make sure you use itunes 10+

  • Brit

    Okay, so i got to the green screen on snowbreeze but when i went to recover, i keep getting error code 1015… what can i do?

  • Mimizone

    there is a bug when using Chinese keyboards and jailbreaking with snowbreeze 2.2.
    it basic crashes when using and switching from Chinese keyboards, or removing Chinese keyboards from the preferences.

    a thread started here:
    http://xsellize.com/topic/115667-chinese-keyboardlanguage-causes-springboard-crash-sn0wbreeze-22-bug/

  • Jayson

    Sn0wbreeze is Open Source! Google search it, and and can edit it in VB 2008! I did it, but it won’t compile, I get an error, something about certifactes… WTH???

  • Ali Imam

    Anybody can help me : I updated my iphone 3G with 4.2 also unlocked via ipad bb (06.15) but after few months when I want to restore it again to 4.2 its stuck on itunes logo? cant kick it any way. Pls. help me anybody knows t he way to restore 4.2 bb 06.15. Plz help me anybody

  • thorpex

    Why was my comment stating the bug when using Chinese keyboard removed?
    Anytime a Chinese is used it basically crashes the springboard to safe mode.

  • adawg

    Can this jailbreak activate iphone 4 without sim?

  • http://iphonehacks Graham

    iphone4 at 4.2.1 via itunes and baseband 3.10.01. Want to unlock, what method can be used now..can take some risks rather than wait ?

  • trimmer

    how do i get the 4.2.1 firmware??

  • Dave

    I had to downgrade back to 3.1.2 in order to get gps working I’ve tried 4.0 up to 4.2.1 and the gps does not work ant idea if and when this problem will be resovled

  • http://www.LocalPosition.com Local Position

    I think it’s best to wait for an update to ultrasn0w, or a new method that can unlock a legitimate baseband.

  • ivdezine

    Can anyone tell me if it’s possible to do a untethered jailbreak and unlock on an iPhone 3GS. Here’s my version info:

    Version: 4.2.1 (8C148a)
    Modem Firmware: 05.15.04

    Any input and guidance would be appreciated. I’m getting ready to travel overseas so would love to have this unlocked beforehand.

  • BLAQ

    how long thus this waiting foriBSS last?…its taking forever…what should i do…pls help.ty

  • Ashisharma

    Ive got a new 3gs with 3.1.3 firmware
    and bb 05.12.01
    can i update to custom 4.2.1 by snOwbreeze and jailbreak….
    ??
    My iphone is currently locked:(( and i need to know if that can be done once i jb with custom IP

  • mahendra

    help needed please……..iphone 3G.
    version 4.2.1
    firmware 05.15.04
    how do i jailbreak this one, my contract will be over soon and the phone will be mind ,so i will ring them up to unlock it.but i want to jailbreak it now,so please help me if you can,thanks!!!!

  • putra97

    hello….anyone can help me on jailbreaking & unlock my ip4 (4.01, BB 01.59.00)..i mean untethered one…plzzzzz..

  • putra97

    ….oooops i mean after i upgrade to 4.2.1 os…thanks..

  • Stando

    One person posted a similar question to mine, maybe you can help me out.
    I have a 3gs that is jailbroken, unlocked, 4.2.1, 06.15.00, Tmobile. My friend did this for me back in November and it works great but I’d like to be able to reboot untethered. I use redsnow 0.9.6rc8 on Win7 right now to boot tethered. What would I need to change to accomplish this?
    Thanks in advance.

  • Ahrpee

    Im new with iphone so pls bare with me. Is it possible to unlock my iphone 3gs iOS 4.2.1 baseband 05.15.04? I’ll appreciate any help. Thanks

  • oshane

    were is the download button assholes

  • James

    I currently have an iPhone 3GS with siftware version 4.2.1, baseband 05.15.04. Can I jailbreak and unlock this myself? Please help!

  • wavecloud

    i am not getting signal on my iphone 3gs ios 4.3.3 with ipad baseband 6.15.It was unlocked with ultrasn0w 1.2.3 can anybody help me to fix the sigal problem?

  • http://www.youtube.com jhanzeb

    Slam

  • Nikita

    Hi. Wanna ask only one thing: I’m having iPhone 3G on IOS 4.1 (8B117) 05.14.02 it is jailbroken, i don’t need to unlock it. Can I update it whith the help of this jail? (without loosing settings) Very very need your answer! I saw the same answers without replies… Help!

    Thanks to you, if you’d answered!

  • p

    Question:
    i have iphone 4 AT&T im using gevey sim, iOs 4.2.1 with a basedband of 03.10.01 if i will jailbreak it wil the unlock remove? because now a days we some issues regarding those iphone 4 users updated their baseband to 4.11.08 are stock to lock and is this redsn0w new version will work for me?

  • SexySpark

    Hello All.

    I am very new to Jailbreaking and have recently got an iPhone 4S.
    My old iPhone 3G has been repaired and i wanted to Jailbreak and Unlock it for use by my daughter as she is on Orange Tarrif.
    Phone Model: iPhone 3G (MB489B)
    Version: 4.2.1
    Modem Firmware: 05.15.04

    Any help is appreciated.

    Regards

    Sexyspark

  • vishnu

    please some say how to jailbreak ipod touch 2g mc model 4.2.1 i tried with greenpoise it install but while installing cydia showing memory not enough i tried with redsn0w it didnt work at all

  • cahs

    hi i have an iphone 3g with a bb 5.11.7 running on ios 3.1.2 is it safe to use sn0wbreeze 2.2 to unlock and jailbreak?

  • http://pc-extreme jonhs

    i have 3g model MB489B bootloader 06.04 (g2m3s2) and baseband ICE2-06.15.00 Os version 4.1 please i downgrade baseband i have problem for singal. :(

  • imran

    hi
    I am having iphone4,when i want ton on that it have apple icon,
    plz help me
    thanks
    regards

  • Parker

    I’ve done my homework with regards to jailbreaking an iPhone 3g with iOS 4.2.1 and bb 05.15.04. It requires iPad bb and you there is a good chance that you will lose GPS. Also, there is no way of going back to stock bb or firmware.
    You’ve been warned!!
    I won’t be jailbreaking…. too bad.