JailbreakMe 3.0 Released To Jailbreak iPhone 4, iPhone 3GS, iPad 2, iPad 1, iPod Touch 4G, iPod Touch 3G On iOS 4.3.3 Using Mobile Safari

JailbreakMe 3.0

As rumored, Comex has just released the eagerly awaited JailbreakMe 3.0 for iOS 4.3.3.

JailbreakMe 3.0 makes use of a PDF exploit just like JailbreakMe 2.0. Comex’s solution is the mother of all jailbreaking solutions as you can jailbreak your iOS device using mobile Safari.

It works on all iOS devices such as iPhone 4, iPhone 3GS, iPad 1, iPad 2, iPod Touch 3G and iPod Touch 4G.

Few things that you should do or know before you proceed:

  • It is always a good idea to take a backup of your iOS device before you hack it, refer to this post for more details.
  • JailbreakMe 3.0 supports the following iOS devices and firmware, so please ensure your iOS device is running the supported iOS firmwares (Settings -> General -> About -> Version):
    • iPad1: 4.3 through 4.3.3
    • iPad2: 4.3.3
    • iPhone3GS: 4.3 through 4.3.3
    • iPhone4: 4.3 through 4.3.3
    • iPhone4-CDMA: 4.2.6 through 4.2.8
    • iPod touch 3g: 4.3, 4.3.2, 4.3.3
    • iPod touch 4g: 4.3 through 4.3.3
  • Please note that JailbreakMe does not hactivate your iPhone, so your iPhone should be activated via iTunes first.
  • JailbreakMe does not unlock your iPhone. So iPhone unlockers are advised to use tools like PwnageTool or Sn0wbreeze to jailbreak their iPhone.

All you need to do is visit JailbreakMe.com on your iPhone, iPod Touch or iPad’s Mobile Safari browser and tap on the Free button under Cydia and then tap on the Install button, this should jailbreak your iOS device and install Cydia (as seen in the screnshot below) just like installing an iOS app from the App Store. It is as easy as that.

You can checkout the video guide to jailbreak iPhone or iPod Touch using JailbreakMe 3.0 below:

You can checkout the video guide to jailbreak iPad 2 or iPad 1 using JailbreakMe 3.0 below:

Kudos to Comex for all the hard work.

Update 1:

If you’ve any problems, try to reboot your iOS device and try again. Please remember that JailbreakMe supports iOS 4.3.3 so please go through the points mentioned above.

Update 2:

Checkout the JailbreakMe 3.0 FAQ, known issues and more.

Update 3:

Install PDF Patcher 2 To Fix JailbreakMe 3.0 Vulnerability

Update 4:

Updated the article with the iOS devices and firmware supported (thanks everyone)

Please let us know how it goes in the comments.

Like this post? Share it!