Sn0wbreeze 2.8 Beta 6 To Jailbreak iOS 5 Beta 6 For iPhone, iPad & iPod Touch Released

Sn0wbreeze

iH8sn0w has just released Sn0wbreeze 2.8 beta 6 to jailbreak iOS 5 beta 6 for iPhone, iPad and iPod Touch that was seeded to developers of iOS developer program on Friday.

The beta version is meant for developers of jailbreak apps and tweaks, so that they can test and debug their software on iOS 5 beta.

Sn0wbreeze is considered the unofficial PwnageTool for Windows. It allows users to create custom iOS 5 beta 6 firmware file that is pre-jailbroken, which can be used to upgrade their iPhone, iPad or iPod Touch to iOS 5 beta 6. In case of iPhone, it also preserves the baseband from getting upgraded so that it can be unlocked using Ultrasn0w.

According to the release notes, Sn0wbreeze 2.8 beta 6 includes the following features:

  • Still has ability to Hacktivate. 
  • Still removes UDID developer check/Beta Timer. 
  • Still preserves the baseband (as always). 
Sn0wbreeze 2.8 beta 6 supports the following iOS 5 devices:

Sn0wbreeze 2.8 beta 6 still cannot jailbreak iPad 2. It supports an untethered jailbreak for iPhone 3GS (old bootrom), while it supports only a tethered jailbreak for the remaining iOS 5 devices mentioned above, which means that you need to connect your iOS device to the computer on every reboot.

You can download Sn0wbreeze 2.8 beta 6 for Windows using this link.

As always, let us know how it goes.

[via Twitter (iH8sn0w)]

Categories: iOS 5, 5.0.1, 5.0.2, Jailbreak iOS 5, 5.1.1, 5.1, 5.0.1, Jailbreak iPad, Jailbreak iPhone, Jailbreak iPod touch, Sn0wbreeze

« | »

  • Jack Black

    First!!

  • http://www.motorbeam.com/ fas

    This is just for the devs, right?

  • kelmond

    WORKS. tried! for those using windows and need ipsw instead of .dmg, download poweriso and convert.
    google is your best friend(:

    • http://N/A Jason

      I tried, downloaded the IOS5 beta 6, converted it the .ispw by changing the name. When I try to put that into snowbreeze… it says that ISPW is invalid? Any help guys would be great?

      Thanks,

      Jason

      • Alex

        Try going to imzdl.com, it has the file as a direct ipsw so it will work

  • Kerdy

    Tried with my CDMA iPhone 4 and it installs fine but fails to activate. Can anyone confirm this works with the Verizon iPhone 4?

    • RoyalCask

      I get the same results, on my Verizon CDMA iPhone 4. The signal goes from having service, to one bar, to searching… I’ve gone back to beta 5 until I can figure it out.

      • Chrussell1215

        I am having the same problems. Signal goes from 1 bar to 4 to searching… anyone know how to fix this?

  • Mo kash

    Can I down grade back 4.3… After

    • Guru

      As long as you have a copy of your SHSH blob for 4.3 then Yes you can downgrade.

  • Notluf

    Word of warning for those running VMWare Workstation, kill all VMWare processes, especially the VMWare USB Arbitration Service. Kill the VMWare Workstation Tray process too. Once all of those are killed then the hack can begin! If anything VMWare is running then you will get 1600 error codes from iTunes. 16xx codes are all USB related and VMWare hooks onto the USB at the kernel level and messes with the JB process.