Dev Team Warn Jailbreakers to Avoid Updating to iOS 5.1.1


Jailbreak iPod Touch On iOS 4.2.1 Redsn0w

Apple has just released iOS 5.1.1 for iPhone, iPad and iPod touch, which includes some improvements and bug fixes.

However, MuscleNerd of iPhone Dev team has just tweeted that jailbreakers should not update to iOS 5.1.1, especially iPhone 4S, iPad 2 and iPad 3 users if they want to jailbreak their iOS device.

MuscleNerd of iPhone Dev team just tweeted:

iOS 5.1.1 is out…jailbreakers beware!  Owners of iPhone4S or iPad2/3 should stay away from it!

On the other hand, tinkerers with older devices can tether jailbreak 5.1.1 using last month’s redsn0w (just pre-select the 5.1 IPSW)

While it is still possible to use Redsn0w to (tethered) jailbreak iPhone 4, iPhone 3GS, iPad 1, iPod touch 4G and iPod touch 3G on iOS 5.1.1, it is not clear if the exploits that pod2g has discovered in iOS 5.1 for the untethered jailbreak have been patched by Apple in iOS 5.1.1 as pod2g hasn’t said anything about the latest iOS software update yet.

So it is advisable that iPhone 4, iPhone 3GS, iPad 1, iPod touch 4G and iPod touch 3G to avoid updating to iOS 5.1.1 if they want an untethered jailbreak.

Please don’t forget to take a backup of SHSH blobs and BBTickets. You can check out this post for more details.

We’ll let you know as soon as we get any more details so stay tuned at iPhone Hacks or join our Facebook Fan page or follow us on Twitter or add us on Google+ or subscribe to our RSS feed.

Like this post? Share it!