VIP Mailbox & Shared Photo Stream Also Available on iPhone 3GS, iPod Touch 4G With iOS 6 Beta 3

iOS 6

Yesterday, we noted (thanks to tip from our reader Mark) that the VIP Lists and VIP mailbox feature, which was only available on iPhone 4 or later, was also available on iPhone 3GS and iPod Touch 4G with iOS 6 beta 3 update.

It looks like Photo`Stream, which was also available only on iPhone 4 or later, is also available on iPod Touch 4G with iOS 6 beta 3 update according to a tip from our reader Gabe.

When we reported about the VIP feature coming to iPhone 3GS, we were not sure if Apple had accidentally added it in iOS 6 beta 3 as the footnote on the iOS 6 preview page still stated that the feature was only available on iPhone 4 or later (and no mention of iPod touch).

Eric Slivka of MacRumorshas noticed that Apple has removed the following footnote fro- the iOS 6 preview page that outlines various restrictions on features:

- Shared Photo Streams requires iOS 6 on iPhone 4 or later or iPad 2 or later, or a Mac computer with OS X Mountain Lion. An up-to-date browser is required for accessing shared photo streams on the web.

- VIP list and VIP and Flagged smart mailboxes will be available on iPhone 4 or later and iPad 2 or later.

So it looks like the Shared Photo Streams and VIP List & mailbox will be available on older devices such as iPhone 3GS and iPod Touch 4G as well. The Flagged smart mailbox feature however still doesn’t seem to be available on the older iOS devices.

We were quite surprised when these two features were not available on older iOS devices, so it is good to see Apple backtracking and adding these features for older iOS devices as well.

Thanks Mark and Gabe for the tips!

You can check out this post for the list of features that are not available on older iOS devices.

Like this post? Share it!

  • Ed

    I have got my 3GS installed with the new iOS update, the problem i have is apple servers are not letting me join the network. I got no network access and looks like now i got to downgrade it back to 5.01 from DFU mode.