evasi0n 1.4 to Jailbreak iOS 6.1.2 Will Be Released Today

evasi0n-icon

Apple just released iOS 6.1.2 to fix the Exchange Calendar bug.

If you’re worried about jailbreaking your iOS device, then the good news is that planetbeing of the evad3rs dev team has just confirmed that the evasi0n jailbreak still works with iPad mini and iPhone 5 on iOS 6.1.2.

They’re still in the process of testing iOS 6.1.2 on other devices.

They will need to update the evasi0n tool for iOS 6.1.2 as evasi0n 1.2 won’t support it. So if you’ve already jailbroken your iOS device, then you may want to wait for evad3rs dev team to release it.

Update 1:

planetbeing has just confirmed that they’ll be releasing evasi0n 1.4 that supports iOS 6.1.2, which means that it will support all iOS 6.1.2 compatible devices:

Update 2:

As promised, evad3rs dev team has just released evasi0n 1.4 for iOS 6.1.2 jailbreak.

Update 3:

Check out our step-by-step guide on how to jailbreak iOS 6.1.2 with evasi0n 1.4 in case you need any help.

We’ll let you know as soon as there is any updates, so don’t forget to join our Facebook Fan page or follow us on Twitter or add us on Google+ or subscribe to our RSS feed.

Categories: evad3rs, Evasi0n Jailbreak, Jailbreak Apple TV, Jailbreak iOS 6.1, Jailbreak iPhone, Jailbreak iPhone 4, Jailbreak iPhone 4S, Jailbreak iPhone 5, iPhone 5s, iPhone 5c, Jailbreak iPod touch, planetbeing

Related

« | »

  • dt56

    yes!!!

  • Mahmoud Ahmadinejad

    Yeah!! :-D

  • genXhippie

    Yes! Great to hear thus far. I had taken my iP5 in several day ago to be serviced, due to stuck pixels. I was dreading this update simply out of fear of losing the opportunity to jailbreak again,once I get the iP5 back.

  • http://rounak.me/ Rounak Jain

    Woohoo!

  • MikeB

    What about the IPhone 4S?

  • Izzy

    I have problem with my yahoo.com website on my iphone 5 and ipad mini and it started since i jailbroke them. Anyway to fix it?

  • macdaddy

    me have 1 iphone 5. me jalbrek today. me want tu du OTA tu 6.1.2 is dis possible?

    • http://www.facebook.com/ralph.rittle Ralph Rittle III

      You have to update through Itunes not OTA for some reason they have issues when Jailbreaking OTA firmware

  • Jr Serna

    when??????????????????????????????

  • http://www.facebook.com/ralph.rittle Ralph Rittle III

    Nice to see that on 2 updates from apple they haven’t stopped Evasi0n… :)

  • peros

    YES!!!!!!!!!!

  • DocACE911

    I hope they block Appysync and Appcake. Gives us all a bad name (although I wish more of the $25 apps like OpenOffice had demos)….
    They blocked Appsync in 1.3 right?

  • Guest

    Evasi0n 1.4 released

    • http://www.iphonehacks.com iPhoneHacks

      Still seeing links to v1.3 on evasi0n’s website.

  • iGhozt702

    Evasi0n 1.4 released :)

    • http://www.iphonehacks.com iPhoneHacks

      Thanks for the tip!

  • DocACE911

    I hope they also blocked appsync and appcake etc with this release like 1.2 and above. It give legitmit cydia people a bad name.

  • Nina

    I bought a Virgin Mobile iPhone 4, I did everything, Cydia is here but when I insert my Fido SIM card : Invalid SIM card. I don’t understand, I did it twice, I restaure each time my iPhone.. but nothing ! Guys, give me a solution, thanks a lot.

  • bullo tadi45

    Yes. i have already jailbreak for ipod touch but cydia problem make empty how???

  • Noff345

    i dont understand how to jailbreak. where do i download evasion