Ultrasn0w 1.2.8 For iOS 6.1 Released

ultrasn0w

If you depend on Ultrasn0w, the software based solution to unlock your iPhone then we have some news.

Yesterday, MuscleNerd of the evad3rs dev team revealed that he had released a new version of Ultrasn0w for iOS 6.1 along with the launch of the evasi0n jailbreak on Monday.

MuscleNerd tweeted that Ultrasn0w 1.2.8 is compatible with iOS 6.1.

Just like the previous versions, Ultrasn0w 1.2.8 will only support the older basebands such as 04.26.08, 05.11.07, 05.12.01, 05.13.04, and 06.15.00 for iPhone 3GS and baseband 01.59.00 for iPhone 4.

If you want to unlock your iPhone using Ultrasn0w then it is important to preserve the baseband using tools like Sn0wbreeze and Redsn0w to upgrade to iOS 6.1.

Due to availability of cheap IMEI based permanent unlocking solutions and legality of unlocking in countries like the U.S, we doubt Ultrasn0w will ever be updated for basebands for the newer devices.

Thanks everyone for the tip!

Like this post? Share it!