Fix CPP: 158 Error Affecting Yalu iOS 10.2 Jailbreak Users on Windows With Cydia Impactor 0.9.39


Jailbreak iOS 10.2 - iOS 10

A lot of jailbreak users have been getting errors while using Cydia Impactor, a tool that allows users to install unsigned apps on their iPhone, iPad or iPod touch, and can be used to install the Yalu Jailbreak IPA file to ultimately jailbreak the iPhone, iPad or iPod touch.

Since Yalu Jailbreak is a semi-tethered jailbreak, one has to re-jailbreak your iOS device. However, since yesterday, users have been reporting that they’re getting the following error while using Cydia Impactor:

htt-win.cpp: 158
Peer certificate cannot be authorized with give CA certificates SSL certificate problem: self signed certificate chain

The issue seems to be affecting only Windows users.

How to Fix CPP: 158 Error Affecting Yalu iOS 10.2 Jailbreak Users on Windows With Cydia Impactor 0.9.39 

The good news is that Saurik has released a new version of Cydia Impactor (0.9.39), which should fix the issue. Saurik has said that it fixes the SSL certificate verification error seen while signing IPA files on Windows.

If you’re facing the CPP: 158 error, then delete Cydia Impactor from your computer and redownload the latest version of Cydia Impactor from this link to avoid the issue.

Let us know how if the new version of Cydia Impactor fixes theCPP: 158 error.

If you need help on how to jailbreak your iPhone, iPad or iPod touch using Yalu Jailbreak, then check out our step-by-step guide:

➤  How to Jailbreak iOS 10.2 on iPhone or iPad Using Yalu Jailbreak and Cydia Impactor

If you’re facing provision.cpp:150 error then check our post on how to fix it:

➤ How to Fix “provision.cpp:150” Error in Cydia Impactor When Jailbreaking iOS 10 – iOS 10.2 Using Yalu

Don’t forget to join our Facebook Fan pagefollow us on Twitteradd us to your circles on Google+subscribe to our RSS feed or our Daily Newsletter for the latest jailbreak news.

Like this post? Share it!

Related Topics: Hacks, Yalu Jailbreak