How To Save SHSH Blobs Using TinyUmbrella

You can follow these simple steps to save SHSH blobs of your iPhone, iPad or iPod Touch.
  • Download the latest version of TinyUmbrella from here
  • Connect your iOS device to the computer
  • Install and then launch the latest version of TinyUmbrella
  • Select your iOS device from the “Connected Devices” list in the left hand panel.
  • If you have not jailborken your iOS device yet, then click on the Advanced tab and deselect “Request SHSH from Cydia” option. If you have jailbroken your iOS device and launched Cydia, then you can skip this step.
  • Then click on the “Save SHSH” button.

After the SHSH blobs are successfully saved, you should see your iOS device listed along with the iOS version that it is running on currently under the General section, which says Saved SHSHs.

Like this post? Share it!

  • genXhippie

    Just saved the shsh for my jailbroken iPad 3, thanks.

  • James

    I have a 16gig white 4s running 5.1.1 untethered jailbreak, I want to upgrade to ios6 but I tried saving my SHSH blobs but it gave me an error saying ”

    9/19/2012 16:27:58.346 CYDIA
    DOES NOT
    HAVE YOUR SHSH FOR iPhone4S 6.0b1 (10A5316k) THERE IS NO
    WAY FOR YOU TO GET THEM. SORRY. YOU ARE JUST TOO LATE.”

    is this correct? or is it a false error? what is wrong?

  • Jon

    I might be wrong but the 6.0b1 after your iPhone 4S would suggest that you’re already on iOS 6 beta 1, which is why you get the message that its too late to get your 5.1.1 SHSH blobs

  • SteveO

    I have a iPhone 4, osi 5.0.1. Can I upgrade to 5.1.1 and save my SHSH? Where do I fine 5.1.1? Thanks.

  • vinay khunt

    i have iphone 4 ios6. i have shsh blog for ios 5.0.1 and i have downgrade ios 5.1.1 , how it posible

  • vinay khunt

    i have a iphone 4. running on ios6 i have shsh blobs for ios 5.0.1 , i want to downgrade ios 5.1.1 how to posible it.

    • http://www.iphonehacks.com iPhoneHacks

      You will be able to downgrade to iOS 5.0.1 and not iOS 5.1.1 as you need iOS 5.1.1 SHSH blobs to downgrade to iOS 5.1.1.

  • http://twitter.com/orebobo Kachi

    HELP Needed!!!!!

    My Iphone 4 is on 04.12.02, 6.0.1 (10A523) and i cant access my mails, calender and cydia!

    Please
    i want to downgrade to 5x and is there anything or info as regards to
    why i cant access my emails, safari, calender, cydia etc???

    I am running bunkers already!!!

  • Wan

    I have iphone 5 6.1.4 can it be downgrade to 6.1.x

  • iPhone-Mohammed

    I have iPhone 4 CDMA – iOS 7.0.2 ….. I am using TinyUmbrella to save SHSH Blobs …. It’s just saving 7.0 and 7.0.2 … It’s not saving 6.1.3 or older …. I want to downgrade from iOS 7.0.2 to iOS 6.1.3 or older …. Any help – How to save SHSH Blobs 6.1.3 or older …… Please reply

    • Gautam

      You can’t save iOS 6.1.3 SHSH blobs now as Apple has stopped signing iOS 6.1.3 firmware files.

      • iPhone-Mohammed

        Thanks for you’r reply