Photos Disappearing due to a Bug in iPhone OS 3.0?

iPhone OS 3.0

Based on this Apple Discussions thread, it looks like there is a bug in iPhone OS 3.0, it is not a critical bug but an annoying one.

Users are complaining that photos taken using iPhone's camera can't be accessed from the built-in Photo app or can't be seen in iPhone's camera roll, they seem to disappear.

According to iLounge, the bug appears to pertain only to photos with the name IMG_10000 or higher.

The strange bug was first reported by jmcfail:

"Moved from the 3G to the 3Gs, new pics that I have taken do now show up in the camera roll."

Alex later confirmed that he was facing a similar issue:

"I have had the same or similar problem for the last week (on a six-month old iPhone 3G 16gig). Neither.
camera photos, images saved from the web, or iPhone screenshots are
showing up in the Camera Roll. I haven't been bent out of shape yet
because the iPhone's Camera Roll keeps a correct cumulative count, and
I have no problem 'seeing' and transferring the images files to my
MacBook and MacBook Pros using iPhoto '09 software. It's becoming
annoying enough now for me to fix it."

According to iLounge, the bug appears to pertain only to photos with the name IMG_10000 or higher. You can't access the photos using the Photo app or see them in the Camera roll. However, as Alex mentioned above, the photos are still on the iPhone and can still be imported either using iPhoto on the Mac or any image viewer on Windows.

iLounge also reports that there is another iPhone OS 3.0 photo-related problem, in which the photos that are taken using iPhone's camera are reported as missing by iPhoto during the import process.

Have you observed this strange issue, if so let us know in the comments. We'll let you know if we get an update on the issue.

[via iLounge]