Apple begins blocking unsafe Adobe Flash plugins in Safari

Adobe Flash blocked in Safari

Apple has begun blocking old and unsafe Flash plugins in Safari for Mac OS X. The move comes after yet another critical vulnerability was discovered in Adobe’s platform last week.

Adobe has already rolled out a fix for the vulnerability, which “could cause a crash and potentially allow an attacker to take control of the affected system.” the company said. But not all OS X users have installed that patch yet.

So to protect those who are still using older versions of Flash, Apple is blocking unsafe plugins.

In a support document on its website, the company explains, “If you’re using an out-of-date version of the Adobe Flash Player plug-in, you may see the message “Blocked plug-in,” “Flash Security Alert,” or “Flash out-of-date” when attempting to view Flash content in Safari.”

Apple provides a shortcut in Safari to download the latest version of Flash, which includes Adobe’s patch. And if you really need to use an older version for some reason, Apple lets you do so in unsafe mode “for websites that you trust.”

[via AppleInsider]