Users on Older Versions of iOS, macOS, and tvOS Won’t Be Able to Update iTunes and App Store Payment Info After June 30

iOS 11 App Store

Apple is making a pivotal change to older versions of iOS, tvOS, and macOS wherein users will be unable to change the payment information on their devices. This move isn’t a result of a security breach, but merely a measure taken to ensure that customers switch over to newer versions of the respective operating system.

Apple is sending emails to its customers informing them of the change. The email details the devices that will be affected:

  • iOS 4.3.5 or earlier
  • macOS 10.8.5 or earlier
  • Apple TV Software 4.4.4 or earlier

This move will come into effect starting June 30, so if you have any devices running on older software versions, now might be the right time to get an update. Apple here is pretty much forcing their hand on the customers, and rightly so, since iOS has evolved a great deal over the past few years, and it makes sense to allow change of payment information only on newer operating systems.

In addition to sending an email to its customers, Apple has also mentioned the changes on its support page, offering all the information on the process.

Do you have an iPhone, Mac or Apple TV running older software versions? What do you make of this change?

[Via Apple Support]